<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<!-- For third-generation iPad with high-resolution Retina display: -->
<link rel="apple-touch-icon" sizes="144x144" href="https://insidehpc.com/wp-content/themes/news-hpc/images/apple-touch-icon-144x144.png">
<!-- For iPhone with high-resolution Retina display running iOS ≥ 7: -->
<link rel="apple-touch-icon" sizes="120x120" href="https://insidehpc.com/wp-content/themes/news-hpc/images/apple-touch-icon-120x120.png">
<!-- For iPhone with high-resolution Retina display running iOS ≤ 6: -->
<link rel="apple-touch-icon" sizes="114x114" href="https://insidehpc.com/wp-content/themes/news-hpc/images/apple-touch-icon-114x114.png">
<!-- For first- and second-generation iPad: -->
<link rel="apple-touch-icon" sizes="72x72" href="https://insidehpc.com/wp-content/themes/news-hpc/images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="57x57" href="https://insidehpc.com/wp-content/themes/news-hpc/images/apple-touch-icon-57x57.png" />
<!-- For non-Retina iPhone, iPod Touch, and Android 2.1+ devices: -->
<link rel="apple-touch-icon" href="https://insidehpc.com/wp-content/themes/news-hpc/images/apple-touch-icon.png">
<link rel="shortcut icon" href="https://insidehpc.com/wp-content/themes/news-hpc/images/favicon.png" type="image/x-icon" /> <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        <script>
            var wpdm_site_url = 'https://insidehpc.com/';
            var wpdm_home_url = 'https://insidehpc.com/';
            var ajax_url = 'https://insidehpc.com/wp-admin/admin-ajax.php';
            var wpdm_ajax_url = 'https://insidehpc.com/wp-admin/admin-ajax.php';
            var wpdm_ajax_popup = '0';
        </script>


        <title>PNNL’S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads - insideHPC</title>

<!-- This site is optimized with the Yoast SEO plugin v11.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="PNNL’S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads - insideHPC" />
<meta property="og:description" content="Pacific Northwest National Lab sent along this article today by PNNL’s Allan Brettman, who writes about the advanced techniques used by the lab’s Center for Advanced Technology Evaluation (CENATE) “to judge HPC workload legitimacy that is as stealthy as an undercover detective surveying the scene through a two-way mirror.” This includes machine learning methods, such &hellip;" />
<meta property="og:url" content="https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/" />
<meta property="og:site_name" content="insideHPC" />
<meta property="article:tag" content="Department of Energy" />
<meta property="article:tag" content="DOE" />
<meta property="article:tag" content="hpc" />
<meta property="article:tag" content="Machine Learning" />
<meta property="article:tag" content="Pacific Northwest National" />
<meta property="article:tag" content="PNNL" />
<meta property="article:tag" content="Supercomputers" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2020-10-28T18:13:23-07:00" />
<meta property="og:image" content="https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020.jpg" />
<meta property="og:image:secure_url" content="https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020.jpg" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="375" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://insidehpc.com/#website","url":"https://insidehpc.com/","name":"insideHPC","potentialAction":{"@type":"SearchAction","target":"https://insidehpc.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/#primaryimage","url":"https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020.jpg","width":500,"height":375},{"@type":"WebPage","@id":"https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/#webpage","url":"https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/","inLanguage":"en-US","name":"PNNL\u2019S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads - insideHPC","isPartOf":{"@id":"https://insidehpc.com/#website"},"primaryImageOfPage":{"@id":"https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/#primaryimage"},"datePublished":"2020-10-28T18:13:23-07:00","dateModified":"2020-10-28T18:13:23-07:00","author":{"@id":"https://insidehpc.com/#/schema/person/cb4fa80db344ea1f481a5d9dc90bbeda"}},{"@type":["Person"],"@id":"https://insidehpc.com/#/schema/person/cb4fa80db344ea1f481a5d9dc90bbeda","name":"staff","image":{"@type":"ImageObject","@id":"https://insidehpc.com/#authorlogo","url":"https://secure.gravatar.com/avatar/29d609e3fe434f5c814bb55c4be8d94d?s=96&d=mm&r=g","caption":"staff"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="insideHPC &raquo; Feed" href="https://insidehpc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="insideHPC &raquo; Comments Feed" href="https://insidehpc.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="insideHPC &raquo; PNNL’S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads Comments Feed" href="https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/insidehpc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='flick-css'  href='https://insidehpc.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='https://insidehpc.com/?mcsf_action=main_css&#038;ver=5.4.2' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='https://insidehpc.com/wp-content/plugins/mailchimp/css/ie.css?ver=5.4.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='wpjobboardwidgetstyle-css'  href='https://insidehpc.com/wp-content/plugins/wpjobboard-widget/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='news-theme-for-inside-hpc-css'  href='https://insidehpc.com/wp-content/themes/news-hpc/style.css?b-modified=1603028298&#038;ver=2.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://insidehpc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='tm_clicktotweet-css'  href='https://insidehpc.com/wp-content/plugins/click-to-tweet-by-todaymade/assets/css/styles.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://insidehpc.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpdm-font-awesome-css'  href='https://use.fontawesome.com/releases/v5.8.1/css/all.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpdm-bootstrap-css'  href='https://insidehpc.com/wp-content/plugins/download-manager/assets/bootstrap/css/bootstrap.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpdm-front-css'  href='https://insidehpc.com/wp-content/plugins/download-manager/assets/css/front.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='social_icons_style-css'  href='https://insidehpc.com/wp-content/themes/news-hpc/css/social-style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='social_icons_app-css'  href='https://insidehpc.com/wp-content/themes/news-hpc/css/social-app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpjb-glyphs-css'  href='https://insidehpc.com/wp-content/plugins/wpjobboard/public/css/wpjb-glyphs.css?ver=5.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpjb-css-css'  href='https://insidehpc.com/wp-content/plugins/wpjobboard/public/css/frontend.css?ver=5.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://insidehpc.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=13.0' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://insidehpc.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpdm_url = {"home":"https:\/\/insidehpc.com\/","site":"https:\/\/insidehpc.com\/","ajax":"https:\/\/insidehpc.com\/wp-admin\/admin-ajax.php"};
var wpdm_asset = {"spinner":"<i class=\"fas fa-sun fa-spin\"><\/i>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/mailchimp//js/scrollTo.js?ver=1.5.7-b-modified-1603028301'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"https:\/\/insidehpc.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/mailchimp//js/mailchimp.js?ver=1.5.7-b-modified-1603028300'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/mailchimp//js/datepicker.js?ver=-b-modified-1603028300'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/download-manager/assets/bootstrap/js/bootstrap.min.js?ver=-b-modified-1603028305'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/download-manager/assets/js/front.js?ver=-b-modified-1603028304'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://insidehpc.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3-b-modified-1603028298'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var WpjbData = {"no_jobs_found":"No job listings found","no_resumes_found":"No resumes found","load_x_more":"Load %d more","date_format":"Y\/m\/d","max_date":"9999\/12\/31"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/wpjobboard/public/js/frontend.js?ver=5.4.0-b-modified-1603028298'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/insidehpc.com\/wp-admin\/admin-ajax.php","security":"3ea1f8c69f","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/insidehpc.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/insidehpc.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.0","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=13.0-b-modified-1603028298'></script>
<link rel='https://api.w.org/' href='https://insidehpc.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://insidehpc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://insidehpc.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/p3RLHQ-moh' />
<link rel="alternate" type="application/json+oembed" href="https://insidehpc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://insidehpc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F&#038;format=xml" />
<style type="text/css">
	#category-posts-2-internal .cat-post-crop {overflow: hidden; display:inline-block}
#category-posts-2-internal .cat-post-item img {margin: initial;}
#category-posts-2-internal .cat-post-thumbnail {float:left;}
#category-posts-3-internal .cat-post-crop {overflow: hidden; display:inline-block}
#category-posts-3-internal .cat-post-item img {margin: initial;}
#category-posts-3-internal .cat-post-thumbnail {float:left;}
#category-posts-4-internal .cat-post-crop {overflow: hidden; display:inline-block}
#category-posts-4-internal .cat-post-item img {margin: initial;}
#category-posts-4-internal .cat-post-thumbnail {float:left;}
#category-posts-5-internal .cat-post-crop {overflow: hidden; display:inline-block}
#category-posts-5-internal .cat-post-item img {margin: initial;}
#category-posts-5-internal .cat-post-thumbnail {float:left;}
#category-posts-6-internal .cat-post-crop {overflow: hidden; display:inline-block}
#category-posts-6-internal .cat-post-item img {margin: initial;}
#category-posts-6-internal .cat-post-thumbnail {float:left;}
</style>
		<link rel="stylesheet" href="https://code.jquery.com/ui/1.10.2/themes/smoothness/jquery-ui.css" />
	<script src="https://code.jquery.com/ui/1.10.2/jquery-ui.js"></script>
	<script src="https://insidehpc.com/wp-content/plugins/google-mp3-audio-player/jquery.ui.touch-punch.js"></script>
	<script src="https://insidehpc.com/wp-content/plugins/google-mp3-audio-player/swfobject.js"></script>
	<link rel="stylesheet" href="https://insidehpc.com/wp-content/plugins/google-mp3-audio-player/style.css" />
	<script type="text/javascript">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</script>
	
	<style type="text/css">
	.codeart-google-mp3-player .download-link{
		display:block;
		padding: 0 5px 0 5px;
		float: left;
	}
	.codeart-google-mp3-player embed{
		float: left;
	}
	.codeart-google-mp3-player{
		overflow: hidden;
	}
	.codeart-google-mp3-player object{
		float: left;
	}
	</style>
	<!--[if gte IE 9]>
		<style type="text/css">
			.gradient {
				filter: none;
			}
		</style>
	<![endif]-->
<script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
   
<!-- Twitter Cards Meta - V 2.5.4 -->
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@insidehpc" />
<meta name="twitter:creator" content="@insidehpc" />
<meta name="twitter:url" content="https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/" />
<meta name="twitter:title" content="PNNL’S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads" />
<meta name="twitter:description" content="Pacific Northwest National Lab sent along this article today by PNNL’s Allan Brettman, who writes about the advanced techniques used by the lab’s Center [...]" />
<meta name="twitter:image" content="https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020.jpg" />
<!-- Twitter Cards Meta By WPDeveloper.net -->

<script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.sovrn.com/static/';
	window._wp_rp_wp_ajax_url = "https://insidehpc.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '86073';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'PNNL%E2%80%99S+CENATE+Taps+ML+to+Guard+DOE+Supercomputers+from+Illegitimate+Workloads';
	window._wp_rp_post_tags = ['supercomputers', 'department+of+energy', 'doe', 'hpc', 'machine+learning', 'pacific+northwest+national', 'pnnl', 'machine+learning', 'news', 'featured', 'research+%2F+education', 'google+news+feed', 'government', 'hpc+hardware', 'hpc+software', 'energi', 'supercomput', 'ferret', 'kevin', 'technolog', 'pacif', 'hpc', 'lab', 'cybersecur', 'comput', 'univers', 'allan', 'nation', 'mirror', 'barker'];
	window._wp_rp_promoted_content = true;
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="icon" href="https://insidehpc.com/wp-content/themes/news-hpc/images/favicon.ico" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-25587466-8"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-25587466-8', {
    'custom_map': {'dimension7': 'Tags', 'dimension8': 'Category'}
  });
  gtag('event', 'tags_dimension', {'Tags': 'Department of Energy,DOE,hpc,Machine Learning,Pacific Northwest National,PNNL,Supercomputers'});
  gtag('event', 'category_dimension', {'Category': 'Featured,Google News Feed,Government,HPC Hardware,HPC Software,Machine Learning,News,Research / Education'});
</script>


<script src="https://cdn.broadstreetads.com/init-2.min.js"></script>
<script>broadstreet.watch({ networkId: 1796 })</script>

<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
 googletag.cmd.push(function() {
googletag.pubads().collapseEmptyDivs();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1061671/IHPC_300x250_InArticle', [300, 250], 'div-gpt-ad-1439400297174-0').addService(googletag.pubads());

    googletag.pubads().addEventListener('slotRenderEnded', function(event){
var str = event.slot.w;
	if(str && str.indexOf('InArticle') > -1)
	{
		if(event.isEmpty)
		{
			jQuery('#desktop-inarticle-ad').hide();
		}
	}
});
    googletag.pubads().enableSingleRequest();
googletag.pubads().setTargeting('Channel', ['Featured', 'Google News Feed', 'Government', 'HPC Hardware', 'HPC Software', 'Machine Learning', 'News', 'Research / Education']);    googletag.enableServices();
  });
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/300x250_IHPC_ROS', [300, 250], 'div-gpt-ad-1407521768957-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().setTargeting('Channel', ['Featured', 'Google News Feed', 'Government', 'HPC Hardware', 'HPC Software', 'Machine Learning', 'News', 'Research / Education']);googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/728x90_IHPC_ROS', [728, 90], 'div-gpt-ad-1407521810586-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().setTargeting('Channel', ['Featured', 'Google News Feed', 'Government', 'HPC Hardware', 'HPC Software', 'Machine Learning', 'News', 'Research / Education']);googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/300x200_IHPC_Videowidget2', [300, 200], 'div-gpt-ad-1408624752654-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/250x900', [250, 950], 'div-gpt-ad-1409672182090-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/250x900_IHPC_RightSkin', [250, 950], 'div-gpt-ad-1409672450439-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});

googletag.cmd.push(function() {
googletag.defineSlot('/1061671/IHPC_ResourceLink_1', [455, 50], 'div-gpt-ad-1410881227361-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/IHPC_ResourceLink_2', [455, 50], 'div-gpt-ad-1410881194676-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/IHPC_ResourceLink_3', [455, 50], 'div-gpt-ad-1410879732407-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/160x600_IHPC_ROS', [160, 600], 'div-gpt-ad-1407521616271-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/180x150_IHPC_ROS', [180, 150], 'div-gpt-ad-1407521647681-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
googletag.cmd.push(function() {
googletag.defineSlot('/1061671/160x200_IHPC_ChannelSponsorship', [160, 200], 'div-gpt-ad-1411648221207-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().setTargeting('Channel', ['Featured', 'Google News Feed', 'Government', 'HPC Hardware', 'HPC Software', 'Machine Learning', 'News', 'Research / Education']);googletag.enableServices();
});
</script>
 <script data-ad-client="ca-pub-4312867285295724" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<link rel="alternate" type="application/rss+xml" title="insideHPC &raquo; Eventlist Feed" href="https://insidehpc.com/feed/event-list" /><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #f9f9f9; }
</style>
	<meta name="generator" content="WordPress Download Manager 4.9.7" />
                    <link href="https://fonts.googleapis.com/css?family=Rubik" rel="stylesheet">
                <style>
            .w3eden .fetfont,
            .w3eden .btn,
            .w3eden .btn.wpdm-front h3.title,
            .w3eden .wpdm-social-lock-box .IN-widget a span:last-child,
            .w3eden #xfilelist .panel-heading,
            .w3eden .wpdm-frontend-tabs a,
            .w3eden .alert:before,
            .w3eden .panel .panel-heading,
            .w3eden .discount-msg,
            .w3eden .panel.dashboard-panel h3,
            .w3eden #wpdm-dashboard-sidebar .list-group-item,
            .w3eden #package-description .wp-switch-editor,
            .w3eden .w3eden.author-dashbboard .nav.nav-tabs li a,
            .w3eden .wpdm_cart thead th,
            .w3eden #csp .list-group-item,
            .w3eden .modal-title {
                font-family: Rubik, -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Helvetica, Arial, sans-serif, "Apple Color Emoji", "Segoe UI Emoji", "Segoe UI Symbol";
                text-transform: uppercase;
                font-weight: 700;
            }
            .w3eden #csp .list-group-item{
                text-transform: unset;
            }

            /* WPDM Link/Page Template Styles */        </style>
                <style>

            :root{
                --color-primary: #4a8eff;
                --color-primary-rgb: 74, 142, 255;
                --color-primary-hover: #4a8eff;
                --color-primary-active: #4a8eff;
                --color-secondary: #4a8eff;
                --color-secondary-rgb: 74, 142, 255;
                --color-secondary-hover: #4a8eff;
                --color-secondary-active: #4a8eff;
                --color-success: #18ce0f;
                --color-success-rgb: 24, 206, 15;
                --color-success-hover: #4a8eff;
                --color-success-active: #4a8eff;
                --color-info: #2CA8FF;
                --color-info-rgb: 44, 168, 255;
                --color-info-hover: #2CA8FF;
                --color-info-active: #2CA8FF;
                --color-warning: #f29e0f;
                --color-warning-rgb: 242, 158, 15;
                --color-warning-hover: orange;
                --color-warning-active: orange;
                --color-danger: #ff5062;
                --color-danger-rgb: 255, 80, 98;
                --color-danger-hover: #ff5062;
                --color-danger-active: #ff5062;
                --color-green: #30b570;
                --color-blue: #0073ff;
                --color-purple: #8557D3;
                --color-red: #ff5062;
                --color-muted: rgba(69, 89, 122, 0.6);
                --wpdm-font: Rubik, -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Helvetica, Arial, sans-serif, "Apple Color Emoji", "Segoe UI Emoji", "Segoe UI Symbol";
            }
            .wpdm-download-link.btn.btn-primary{
                border-radius: 4px;
            }


        </style>
        </head>
<body class="post-template-default single single-post postid-86073 single-format-standard custom-background custom-header header-full-width sidebar-content-sidebar news-hpc"><div id="wrap"><div id="imUtil">
<ul>
<li class="first"><a href="/about/" >About</a></li>
<li><a href="/advertise/" >Advertise</a></li>
<li><a href="/contact/" >Contact</a></li>
</ul>

<form method="get" class="searchform search-form" action="/" role="search"><label for="search-text" class="visuallyhidden">Search: </label><input type="text" id="search-text" value="Search this website…" name="s" class="s search-input" onfocus="if (this.value == 'Search this website…') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this website…';}"><input type="submit" class="searchsubmit search-submit" value="Search"></form>


</div><div id="skins-ad-left"><div id="text-12" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- 250x950_IHPC_LeftSkin -->
<div id='div-gpt-ad-1409672182090-0' style='width:250px; height:950px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1409672182090-0'); });
</script>
</div></div>
		</div></div></div><div id="skins-ad-right"><div id="text-13" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- 250x950_IHPC_RightSkin -->
<div id='div-gpt-ad-1409672450439-0' style='width:250px; height:950px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1409672450439-0'); });
</script>
</div></div>
		</div></div></div><div id="header"><div class="wrap"><div id="title-area">
<h1><a href="/"><img src="/wp-content/themes/news-hpc/images/hpc-logo-stacked.png" alt="Inside HPC" /></a></h1>
</div>
<div class="widget-area">
<div id="text-2" class="widget widget_text">
<div class="widget-wrap">	
<div id="desktop-header-ad">			
<!-- 728x90_IHPC_ROS -->
<div id='div-gpt-ad-1407521810586-0' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1407521810586-0'); });
</script>
</div>
</div> <!-- close desktop-header-ad-->
</div>
</div>
</div> </div></div><div id="nav"><div class="wrap"><ul id="menu-main-navigation" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-38977" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38977"><a href="https://insidehpc.com/category/news-analysis/">News</a>
<ul class="sub-menu">
	<li id="menu-item-38978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38978"><a href="https://insidehpc.com/category/news-analysis/business-hpc/">Business of HPC</a></li>
	<li id="menu-item-38979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38979"><a href="https://insidehpc.com/category/news-analysis/new-installations/">New Installations</a></li>
</ul>
</li>
<li id="menu-item-38980" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38980"><a href="https://insidehpc.com/category/hpc-hardware/">HPC Hardware</a>
<ul class="sub-menu">
	<li id="menu-item-38981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38981"><a href="https://insidehpc.com/category/hpc-hardware/exascale/">Exascale</a></li>
	<li id="menu-item-38982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38982"><a href="https://insidehpc.com/category/hpc-hardware/future-technology/">Future Technology</a></li>
	<li id="menu-item-38983" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38983"><a href="https://insidehpc.com/category/hpc-hardware/compute/">Compute</a></li>
	<li id="menu-item-38984" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38984"><a href="https://insidehpc.com/category/hpc-hardware/coprocessors/">Coprocessors</a></li>
	<li id="menu-item-38985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38985"><a href="https://insidehpc.com/category/hpc-hardware/gpus/">GPUs</a></li>
	<li id="menu-item-38986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38986"><a href="https://insidehpc.com/category/hpc-hardware/storage/">Storage</a></li>
	<li id="menu-item-38987" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38987"><a href="https://insidehpc.com/category/hpc-hardware/network/">Network</a></li>
	<li id="menu-item-38988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38988"><a href="https://insidehpc.com/category/hpc-hardware/green-hpc/">Green HPC</a></li>
</ul>
</li>
<li id="menu-item-38989" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38989"><a href="https://insidehpc.com/category/hpc-software/">HPC Software</a>
<ul class="sub-menu">
	<li id="menu-item-38990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38990"><a href="https://insidehpc.com/category/hpc-software/cloud-hpc/">Cloud HPC</a></li>
	<li id="menu-item-64546" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64546"><a href="https://insidehpc.com/category/hpc-software/machine-learning/">Machine Learning</a></li>
	<li id="menu-item-38991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38991"><a href="https://insidehpc.com/category/hpc-software/tools/">Tools</a></li>
	<li id="menu-item-38992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38992"><a href="https://insidehpc.com/category/hpc-software/systems-management/">Systems Management</a></li>
	<li id="menu-item-38993" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38993"><a href="https://insidehpc.com/category/hpc-software/visualization/">Visualization</a></li>
	<li id="menu-item-38994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38994"><a href="https://insidehpc.com/category/hpc-software/high-performance-analytics/">High Performance Analytics</a></li>
	<li id="menu-item-38995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38995"><a href="https://insidehpc.com/category/hpc-software/lustre/">Lustre</a></li>
	<li id="menu-item-53426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53426"><a href="https://insidehpc.com/category/hpc-software/parallel-programming/">Parallel Programming</a></li>
</ul>
</li>
<li id="menu-item-38996" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-38996"><a href="https://insidehpc.com/category/industry-segments/">Industry Segments</a>
<ul class="sub-menu">
	<li id="menu-item-38997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38997"><a href="https://insidehpc.com/category/industry-segments/enterprise-hpc/">Enterprise HPC</a></li>
	<li id="menu-item-38998" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-38998"><a href="https://insidehpc.com/category/industry-segments/government/">Government</a></li>
	<li id="menu-item-38999" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-38999"><a href="https://insidehpc.com/category/industry-segments/research-education/">Research / Education</a></li>
	<li id="menu-item-51434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51434"><a href="https://insidehpc.com/category/industry-segments/manufacturing/">Manufacturing</a></li>
	<li id="menu-item-39000" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39000"><a href="https://insidehpc.com/category/industry-segments/collaboration/">Collaboration</a></li>
	<li id="menu-item-39001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39001"><a href="https://insidehpc.com/category/industry-segments/datacenter/">Datacenter</a></li>
</ul>
</li>
<li id="menu-item-60320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60320"><a href="https://insidehpc.com/hpc-white-papers/">White Papers</a></li>
<li id="menu-item-39003" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39003"><a href="https://insidehpc.com/category/resources/">Resources</a>
<ul class="sub-menu">
	<li id="menu-item-84422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84422"><a href="https://insidebigdata.com/dell/">Dell Technologies Spotlight</a></li>
	<li id="menu-item-39004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39004"><a href="https://insidehpc.com/category/resources/education-training/">Education / Training</a></li>
	<li id="menu-item-39005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39005"><a href="https://insidehpc.com/category/resources/events/">Events</a></li>
	<li id="menu-item-52555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52555"><a href="/events-calendar/">Events Calendar</a></li>
	<li id="menu-item-39006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39006"><a href="https://insidehpc.com/category/resources/jobs/">Job Postings</a></li>
	<li id="menu-item-39051" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39051"><a href="/jobs/">Jobs Board</a></li>
	<li id="menu-item-39007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39007"><a href="https://insidehpc.com/category/resources/podcast/">Podcast</a></li>
	<li id="menu-item-39008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39008"><a href="https://insidehpc.com/category/resources/research-reports/">Research / Reports</a></li>
	<li id="menu-item-39009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39009"><a href="https://insidehpc.com/category/resources/video/">Video</a></li>
	<li id="menu-item-39010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39010"><a href="https://insidehpc.com/category/resources/industry-perspectives/">Industry Perspectives</a></li>
	<li id="menu-item-39011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39011"><a href="https://insidehpc.com/category/resources/rock-stars-hpc/">Rock Stars of HPC</a></li>
	<li id="menu-item-49018" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49018"><a href="https://insidehpc.com/exascale-report-archives/">The Exascale Report Archives</a></li>
</ul>
</li>
<li id="menu-item-39012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39012"><a href="/white-papers/insidehpc-guide/">Special Reports</a></li>
<li id="menu-item-53427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53427"><a href="https://insidehpc.com/category/hpc-software/parallel-programming/">Parallel Programming</a></li>
</ul></div></div><div id="mc-news" class="wrap"><div id="mailchimpsf_widget-2" class="widget widget_mailchimpsf_widget"><div class="widget-wrap">	<style>
		.widget_mailchimpsf_widget .widget-title {
		line-height: 1.4em;
		margin-bottom: 0.75em;
	}
	#mc_subheader {
		line-height: 1.25em;
		margin-bottom: 18px;
	}
	.mc_merge_var {
		margin-bottom: 1.0em;
	}
	.mc_var_label,
	.mc_interest_label {
		display: block;
		margin-bottom: 0.5em;
	}
	.mc_input {
		-moz-box-sizing: border-box;
		-webkit-box-sizing: border-box;
		box-sizing: border-box;
		width: 100%;
	}
	.mc_input.mc_phone {
		width: auto;
	}
	select.mc_select {
		margin-top: 0.5em;
		width: 100%;
	}
	.mc_address_label {
		margin-top: 1.0em;
		margin-bottom: 0.5em;
		display: block;
	}
	.mc_address_label ~ select {
		width: 100%;		
	}
	.mc_list li {
		list-style: none;
		background: none !important;
	}
	.mc_interests_header {
		margin-top: 1.0em;
		margin-bottom: 0.5em;
	}
	.mc_interest label,
	.mc_interest input {
		margin-bottom: 0.4em;
	}
	#mc_signup_submit {
		margin-top: 1.5em;
		width: 80%;
	}
	#mc_unsub_link a {
		font-size: 0.75em;
	}
	#mc_unsub_link {
		margin-top: 1.0em;
	}
	.mc_header_address,
	.mc_email_format {
		display: block;
		font-weight: bold;
		margin-top: 1.0em;
		margin-bottom: 0.5em;
	}
	.mc_email_options {
		margin-top: 0.5em;
	}
	.mc_email_type {
		padding-left: 4px;
	}
	</style>
	
<div id="mc_signup">
	<form method="post" action="#mc_signup" id="mc_signup_form">
		<input type="hidden" id="mc_submit_type" name="mc_submit_type" value="html" />
		<input type="hidden" name="mcsf_action" value="mc_submit_signup_form" />
		<input type="hidden" id="_mc_submit_signup_form_nonce" name="_mc_submit_signup_form_nonce" value="fd4a646109" />		
			<div id="mc_subheader">
			Sign up for our newsletter and get the latest HPC news and analysis.		</div><!-- /mc_subheader -->
			
	<div class="mc_form_inside">
		
		<div class="updated" id="mc_message">
					</div><!-- /mc_message -->

		
<div class="mc_merge_var">
		<label for="mc_mv_EMAIL" class="mc_var_label mc_header mc_header_email">Email Address</label>
	<input type="text" size="18" placeholder="" name="mc_mv_EMAIL" id="mc_mv_EMAIL" class="mc_input"/>
</div><!-- /mc_merge_var -->				
							<div class="mc_interests_header">
								Send me information from insideHPC:							</div><!-- /mc_interests_header -->
							<div class="mc_interest">
									

					
				
				<input type="checkbox" name="group[d40d3a7d35][9b5b453b1b]" id="mc_interest_d40d3a7d35_9b5b453b1b" class="mc_interest" value="Daily" />
				<label for="mc_interest_d40d3a7d35_9b5b453b1b" class="mc_interest_label">Daily</label>
				<br/>
				
				<input type="checkbox" name="group[d40d3a7d35][b94bf56501]" id="mc_interest_d40d3a7d35_b94bf56501" class="mc_interest" value="Weekly" />
				<label for="mc_interest_d40d3a7d35_b94bf56501" class="mc_interest_label">Weekly</label>
				<br/>				
					</div><!-- /mc_interest -->
			
					
		<div class="mc_signup_submit">
			<input type="submit" name="mc_signup_submit" id="mc_signup_submit" value="Subscribe" class="button" />
		</div><!-- /mc_signup_submit -->
	
	
				
	</div><!-- /mc_form_inside -->
	</form><!-- /mc_signup_form -->
</div><!-- /mc_signup_container -->
	</div></div></div><div id="inner"><div class="wrap"><div id="content-sidebar-wrap"><div id="content" class="hfeed"><div class="breadcrumb"><a href="https://insidehpc.com/"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a> &raquo; <a href="https://insidehpc.com/category/featured/"><span class="breadcrumb-link-text-wrap" itemprop="name">Featured</span></a> &raquo; PNNL’S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads</div><div class="post-86073 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-google-news-feed category-government category-hpc-hardware category-hpc-software category-machine-learning category-news-analysis category-research-education tag-department-of-energy tag-doe tag-hpc-2 tag-machine-learning tag-pacific-northwest-national tag-pnnl tag-supercomputers entry"><h1 class="entry-title">PNNL’S CENATE Taps ML to Guard DOE Supercomputers from Illegitimate Workloads</h1>
<div class="post-info"><span class="date published time" title="2020-10-28T11:13:23-07:00">October 28, 2020</span>  by <span class="author vcard"><span class="fn"><a href="https://insidehpc.com/author/staff/" rel="author">staff</a></span></span> <span class="post-comments"><a href="https://insidehpc.com/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/#respond">Leave a Comment</a></span> <div class="printfriendly"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img src="https://insidehpc.com/wp-content/themes/news-hpc/images/print-icon.gif" alt="Print Friendly, PDF & Email" style="display: inline" /></a></div></div><div class="entry-content"><div class="pf-content"><p><em><img class="alignright  wp-image-59266" src="https://insidehpc.com/wp-content/uploads/2016/06/pnnl2-300x300.jpg" alt="" width="140" height="140" srcset="https://insidehpc.com/wp-content/uploads/2016/06/pnnl2-300x300.jpg 300w, https://insidehpc.com/wp-content/uploads/2016/06/pnnl2-150x150.jpg 150w, https://insidehpc.com/wp-content/uploads/2016/06/pnnl2-110x110.jpg 110w, https://insidehpc.com/wp-content/uploads/2016/06/pnnl2-50x50.jpg 50w, https://insidehpc.com/wp-content/uploads/2016/06/pnnl2.jpg 400w" sizes="(max-width: 140px) 100vw, 140px" />Pacific Northwest National Lab sent along this article today by PNNL’s Allan Brettman, who writes about the advanced techniques used by the lab’s Center for Advanced Technology Evaluation (CENATE) “to judge HPC workload legitimacy that is as stealthy as an undercover detective surveying the scene through a two-way mirror.” This includes machine learning methods, such as recurrent neural networks, that the center has found delivers prediction accuracy of more than 95 percent.</em></p>
<table width="100%">
<tbody>
<tr>
<td width="100%"></td>
</tr>
<tr>
<td width="100%">
<table width="100%">
<tbody>
<tr>
<td width="100%">
<table width="100%">
<tbody>
<tr>
<td>By Allan Brettman</p>
<p>By all appearances, Ang Li and Kevin Barker are computer scientists. But looks can be deceiving.</p><div id="desktop-inarticle-ad">
<!-- /1061671/IHPC_300x250_InArticle -->
<div id='div-gpt-ad-1439400297174-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1439400297174-0'); });
</script>
</div>
</div>

<div id="mobile-inarticle-ad">
<!-- /1061671/IHPC_300x250_InArticle
<div id='div-gpt-ad-1439400297174-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1439400297174-0'); });
</script>
</div>-->
</div>
<p>The Pacific Northwest National Laboratory (<a href="https://info.pnnl.gov/e2t/tc/VVZ7N082XKHHW7_vPNj1HqYBgW3kyKQV4hHZ5SN7-7xy73lGmcV1-WJV7CgKt2W3qhw_D3Hcn0mW60zl4g4-9ncRW8NCvjV71CzrvW7YpR_427HD5XW4yF6k74G5x77W7G5_g954fctkW1y8vJY8dGHnbW6P07174W8bKRW2VJdgg62LHt3W1WZSlb7sstF4W53FGnT4kzQTkW6-5LZp1cxsvjW6zC0vr7YT1pWN3_By4j6-m7mW3FRvk21BRQP_W37cpvs7qzB5wV1ZGZf1NZJ7BW2yf1_53yHfwC31Kx1">PNNL</a>) duo are also high-tech sleuths, training powerful computers to perform gumshoe work protecting the nation from cybersecurity threats.</p>
<p>Li, Barker, PNNL colleagues, and university collaborators have developed a system to ferret out questionable use of high-performance computing (HPC) systems within the U.S. Department of Energy (DOE). As HPC systems become more powerful—arguably the most sophisticated and largest systems in the world—they are under potential threat by attackers seeking to run malicious software.</p>
<p>Tracking down nefarious users is just one example of work at PNNL’s Center for Advanced Technology Evaluation (<a href="https://info.pnnl.gov/e2t/tc/VVZ7N082XKHHW7_vPNj1HqYBgW3kyKQV4hHZ5SN7-7xy73lGmcV1-WJV7CgHpvN5spThQhtKYpW1dH_Yl6kMT1XW52bKCR1szQKRW2M0FLG8vDd0lW1fgxpF7QxFXfW6B63XG3CNhhrW8zbfCk5XBbJZW54qVmM959h5JW8S0h6v8yQprsW4S_TW95Df1RkVChv1L7d7VJ9W8X-KXr8rkQbvVCL2_T2ZX8jvVXc-Pk7YlxZKW5KGxRs2dqrCGN7mVxDK-rFT2W61d_RB8xgf8qVSh4N83pslF0312S1">CENATE</a>), a computing proving ground supported by DOE’s Office of Science. Broadly, CENATE aims to understand the impact of advanced computing technologies on scientific workloads. In this role, Barker, CENATE co-principal investigator David Manz, and colleagues have developed a nonintrusive profiling framework to judge HPC workload legitimacy that is as stealthy as an undercover detective surveying the scene through a two-way mirror.</p>
<p><strong>Removing Intruders</strong></p>
<p>CENATE has led development of machine learning methods such as recurrent neural networks (RNNs) to classify the distinctive signatures of authorized and unauthorized workloads. With a prediction accuracy of more than 95 percent, this open-source framework can assist system administrators in identifying and removing unauthorized workloads and intruders, assuring system availability and integrity for legitimate scientific users.</p>
<div id="attachment_86074" style="width: 341px" class="wp-caption alignright"><img aria-describedby="caption-attachment-86074" class="wp-image-86074" src="https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020-300x225.jpg" alt="" width="331" height="248" srcset="https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020-300x225.jpg 300w, https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020-150x113.jpg 150w, https://insidehpc.com/wp-content/uploads/2020/10/PNNL-CENATE-Ang-Li-1020.jpg 500w" sizes="(max-width: 331px) 100vw, 331px" /><p id="caption-attachment-86074" class="wp-caption-text"><em>PNNL computer scientist Ang Li</em></p></div>
<p>“Machine learning methods are helping us to identify some of the key characteristics of workloads that represent legitimate scientific computing or something that might be anomalous that we would want to look into further,” said Barker, a PNNL computer scientist and CENATE principal investigator. “The machine learning algorithm can learn these patterns by looking at legitimate scientific codes.</p>
<p>“The machine learning algorithm can learn some of these patterns and then learn to distinguish between legitimate codes—something we expect to see—versus something that looks strange to us, something we’ll want to flag for a human operator to look into more deeply.”</p>
<p><strong>Detecting Cyber-fingerprints</strong></p>
<p>As you might suspect, there is not a gigantic data set that can be loaded into a supercomputer named “Catch the Bad Cyber Guys.”</p>
<p>In lieu of available information based on actual nefarious activities, researchers created a data set that reflected known, unallowable characteristics, said Li, a PNNL computer scientist. “We identified codes that illegitimate users might be running,” said Li.</p>
<p>Li and colleagues tapped into publicly available data from sources such as GitHub, GitLab, and Bitbucket to create their own smaller data set, to identify fingerprints of cybersecurity skullduggery such as cryptocurrency applications, password cracking activity, or longer-than-customary computer runtimes.</p>
<p><strong>Trust, but Verify</strong></p>
<p>Malicious codes slink into the worlds of cryptocurrency mining and password cracking, and RNNs are on the lookout for suspect behavior. How much data is being moved from a central processing unit (CPU) to a graphics processing unit (GPU)? What is the power consumption of the GPU memory? Eventually, CENATE computer scientists expect to have a greatly enhanced RNN that can expand the potential for finding anomalous clues in the underworld of malicious codes.</p>
<p>Li and Barker, along with colleagues Pengfei Zou and Rong Ge of Clemson University, <a href="https://info.pnnl.gov/e2t/tc/VVZ7N082XKHHW7_vPNj1HqYBgW3kyKQV4hHZ5SN7-7xyL3lGmQV1-WJV7CgQr9VzqV926lgHwbW7Zwvw15g_jvDW1l49SG1rZNL-W2lR0F32_9b87W78Q-ny4Xf3rxVPd4857FdhMgW6ZYN0X1J2R6hW6Xq4NY4Rb2l_W6PNP-18zH2NVW8vvMn39lg3b9W22dh8r20pgZCW3tdSZJ3gdTYkW8jfYYt6Lmg9wW3pg_pD7xyh29W2PFx1N7LjSCPVkDBQN3mF8vjW7nQ2fV7WsG3hW3jVSVb510NrfW2yDm815xqzRTVJsSdp6Q9MQnN5WN53lmgjpYW2ZW3D17W5MJy33Fq1">published a paper</a> in 2019 for the IEEE International Workshop/Symposium on Workload Characterization that described how machine learning through real-time RNNs could detect illicit use of high-performance computers.</p>
<p>Misusing a supercomputing capability presents several problems, they reported. It not only deprives mission-critical and scientific applications of execution cycles, but also increases the chance for attackers to steal data, damage systems, and leverage the high computation and network bandwidth for attacking other sites.</p>
<p>Prospective users of DOE supercomputing resources undergo a high level of scrutiny before they’re granted access to some of the world’s most sophisticated equipment. That entrée comes with a level of trust, said Barker, which presents a challenge for detecting unauthorized computing.</p>
<p>“Once a user is approved, we kind of trust them to know what they’re doing,” said Barker. “So, having these kinds of automated, machine learning tools can help facility operators with filling that trust gap—to know in real time if a user is not doing what they’re supposed to.&#8221;</td>
</tr>
</tbody>
</table>
</td>
</tr>
</tbody>
</table>
</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
</div><div class="shariff shariff-align-flex-start shariff-widget-align-flex-start" data-services="twitter%7Cfacebook" data-url="https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F" data-timestamp="1603883603" data-hidezero="1" data-backendurl="https://insidehpc.com/wp-json/shariff/v1/share_counts?"><ul class="shariff-buttons theme-color orientation-horizontal buttonsize-medium"><li class="shariff-button twitter shariff-nocustomcolor" style="background-color:#32bbf5"><a href="https://twitter.com/share?url=https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F&text=PNNL%E2%80%99S%20CENATE%20Taps%20ML%20to%20Guard%20DOE%20Supercomputers%20from%20Illegitimate%20Workloads" title="Share on Twitter" aria-label="Share on Twitter" role="button" rel="noopener nofollow" class="shariff-link" style="; background-color:#55acee; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 32"><path fill="#55acee" d="M29.7 6.8q-1.2 1.8-3 3.1 0 0.3 0 0.8 0 2.5-0.7 4.9t-2.2 4.7-3.5 4-4.9 2.8-6.1 1q-5.1 0-9.3-2.7 0.6 0.1 1.5 0.1 4.3 0 7.6-2.6-2-0.1-3.5-1.2t-2.2-3q0.6 0.1 1.1 0.1 0.8 0 1.6-0.2-2.1-0.4-3.5-2.1t-1.4-3.9v-0.1q1.3 0.7 2.8 0.8-1.2-0.8-2-2.2t-0.7-2.9q0-1.7 0.8-3.1 2.3 2.8 5.5 4.5t7 1.9q-0.2-0.7-0.2-1.4 0-2.5 1.8-4.3t4.3-1.8q2.7 0 4.5 1.9 2.1-0.4 3.9-1.5-0.7 2.2-2.7 3.4 1.8-0.2 3.5-0.9z"/></svg></span><span class="shariff-text">tweet</span>&nbsp;<span data-service="twitter" style="color:#55acee" class="shariff-count shariff-hidezero"></span>&nbsp;</a></li><li class="shariff-button linkedin shariff-nocustomcolor" style="background-color:#1488bf"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F&title=PNNL%E2%80%99S%20CENATE%20Taps%20ML%20to%20Guard%20DOE%20Supercomputers%20from%20Illegitimate%20Workloads" title="Share on LinkedIn" aria-label="Share on LinkedIn" role="button" rel="noopener nofollow" class="shariff-link" style="; background-color:#0077b5; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#0077b5" d="M6.2 11.2v17.7h-5.9v-17.7h5.9zM6.6 5.7q0 1.3-0.9 2.2t-2.4 0.9h0q-1.5 0-2.4-0.9t-0.9-2.2 0.9-2.2 2.4-0.9 2.4 0.9 0.9 2.2zM27.4 18.7v10.1h-5.9v-9.5q0-1.9-0.7-2.9t-2.3-1.1q-1.1 0-1.9 0.6t-1.2 1.5q-0.2 0.5-0.2 1.4v9.9h-5.9q0-7.1 0-11.6t0-5.3l0-0.9h5.9v2.6h0q0.4-0.6 0.7-1t1-0.9 1.6-0.8 2-0.3q3 0 4.9 2t1.9 6z"/></svg></span><span class="shariff-text">share</span>&nbsp;</a></li><li class="shariff-button facebook shariff-nocustomcolor" style="background-color:#4273c8"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F" title="Share on Facebook" aria-label="Share on Facebook" role="button" rel="nofollow" class="shariff-link" style="; background-color:#3b5998; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 32"><path fill="#3b5998" d="M17.1 0.2v4.7h-2.8q-1.5 0-2.1 0.6t-0.5 1.9v3.4h5.2l-0.7 5.3h-4.5v13.6h-5.5v-13.6h-4.5v-5.3h4.5v-3.9q0-3.3 1.9-5.2t5-1.8q2.6 0 4.1 0.2z"/></svg></span><span class="shariff-text">share</span>&nbsp;<span data-service="facebook" style="color:#3b5998" class="shariff-count shariff-hidezero"></span>&nbsp;</a></li><li class="shariff-button mailto shariff-nocustomcolor" style="background-color:#a8a8a8"><a href="mailto:?body=https%3A%2F%2Finsidehpc.com%2F2020%2F10%2Fpnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads%2F&subject=PNNL%E2%80%99S%20CENATE%20Taps%20ML%20to%20Guard%20DOE%20Supercomputers%20from%20Illegitimate%20Workloads" title="Send by email" aria-label="Send by email" role="button" rel="noopener nofollow" class="shariff-link" style="; background-color:#999; color:#fff"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path fill="#999" d="M32 12.7v14.2q0 1.2-0.8 2t-2 0.9h-26.3q-1.2 0-2-0.9t-0.8-2v-14.2q0.8 0.9 1.8 1.6 6.5 4.4 8.9 6.1 1 0.8 1.6 1.2t1.7 0.9 2 0.4h0.1q0.9 0 2-0.4t1.7-0.9 1.6-1.2q3-2.2 8.9-6.1 1-0.7 1.8-1.6zM32 7.4q0 1.4-0.9 2.7t-2.2 2.2q-6.7 4.7-8.4 5.8-0.2 0.1-0.7 0.5t-1 0.7-0.9 0.6-1.1 0.5-0.9 0.2h-0.1q-0.4 0-0.9-0.2t-1.1-0.5-0.9-0.6-1-0.7-0.7-0.5q-1.6-1.1-4.7-3.2t-3.6-2.6q-1.1-0.7-2.1-2t-1-2.5q0-1.4 0.7-2.3t2.1-0.9h26.3q1.2 0 2 0.8t0.9 2z"/></svg></span><span class="shariff-text">email</span>&nbsp;</a></li></ul></div></p></div><div class="after-post-ad"><div id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- 180x150_IHPC_ROS -->
<div id='div-gpt-ad-1407521647681-0' style='width:180px; height:150px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1407521647681-0'); });
</script>
</div></div>
		</div></div><div id="wp_related_posts_widget" class="widget widget_wp_related_posts"><div class="widget-wrap">
<div class="wp_rp_wrap  wp_rp_plain" id="wp_rp_first"><div class="wp_rp_content"><h4 class="widget-title widgettitle">Related Content:</h4>
<ul class="related_post wp_rp"><li data-position="0" data-poid="in-85063" data-post-type="none" ><a href="https://insidehpc.com/2020/07/doe-unveils-blueprint-for-unhackable-quantum-internet-central-roles-for-argonne-chicago-university-fermilab/" class="wp_rp_title">DOE Unveils Blueprint for &#8216;Unhackable&#8217; Quantum Internet: Central Roles for Argonne, Univ. of Chicago, Fermilab</a></li><li data-position="1" data-poid="in-85429" data-post-type="none" ><a href="https://insidehpc.com/2020/08/doe-launches-115m-5-year-effort-to-create-5-quantum-research-centers/" class="wp_rp_title">DOE Launches $115M, 5-Year Effort to Create 5 Quantum Research Centers</a></li><li data-position="2" data-poid="in-85347" data-post-type="none" ><a href="https://insidehpc.com/2020/08/lets-talk-exascale-podcast-ecp-leadership-discusses-highlights-challenges-impact/" class="wp_rp_title">Let&#8217;s Talk Exascale Podcast  – ECP Leadership Discuss Project Highlights, Challenges, Impact</a></li><li data-position="3" data-poid="in-85530" data-post-type="none" ><a href="https://insidehpc.com/2020/09/class-of-26-joins-the-doe-computational-science-graduate-fellowship/" class="wp_rp_title">Class of 26 joins DOE Computational Science Graduate Fellowship</a></li><li data-position="4" data-poid="in-85395" data-post-type="none" ><a href="https://insidehpc.com/2020/08/dod-inks-32m-deal-with-liqid-forms-ai-partnership-with-doe-microsoft/" class="wp_rp_title">DOD Inks $32M HPC Deal with Liqid; Forms AI Partnership with DOE, Microsoft</a></li></ul></div></div>
</div></div></div><!-- end .after-post-ad --><div class="post-meta"><span class="categories">Filed Under: <a href="https://insidehpc.com/category/featured/" rel="category tag">Featured</a>, <a href="https://insidehpc.com/category/news-analysis/google-news-feed/" rel="category tag">Google News Feed</a>, <a href="https://insidehpc.com/category/industry-segments/government/" rel="category tag">Government</a>, <a href="https://insidehpc.com/category/hpc-hardware/" rel="category tag">HPC Hardware</a>, <a href="https://insidehpc.com/category/hpc-software/" rel="category tag">HPC Software</a>, <a href="https://insidehpc.com/category/hpc-software/machine-learning/" rel="category tag">Machine Learning</a>, <a href="https://insidehpc.com/category/news-analysis/" rel="category tag">News</a>, <a href="https://insidehpc.com/category/industry-segments/research-education/" rel="category tag">Research / Education</a></span> <span class="tags">Tagged With: <a href="https://insidehpc.com/tag/department-of-energy/" rel="tag">Department of Energy</a>, <a href="https://insidehpc.com/tag/doe/" rel="tag">DOE</a>, <a href="https://insidehpc.com/tag/hpc-2/" rel="tag">hpc</a>, <a href="https://insidehpc.com/tag/machine-learning/" rel="tag">Machine Learning</a>, <a href="https://insidehpc.com/tag/pacific-northwest-national/" rel="tag">Pacific Northwest National</a>, <a href="https://insidehpc.com/tag/pnnl/" rel="tag">PNNL</a>, <a href="https://insidehpc.com/tag/supercomputers/" rel="tag">Supercomputers</a></span></div></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/10/pnnls-cenate-taps-ml-to-guard-doe-supercomputers-from-illegitimate-workloads/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://insidehpc.com/wp-comments-post.php?wpe-comment-post=insidehpc" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" tabindex="4" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" size="30" tabindex="1" aria-required="true" /><label for="author">Name</label> <span class="required">*</span></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" size="30" tabindex="2" aria-required="true" /><label for="email">Email</label> <span class="required">*</span></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" size="30" tabindex="3" /><label for="url">Website</label></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='86073' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e9eb8d4dca" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="64"/></p></form>	</div><!-- #respond -->
	<div class="after-post-ad widget">
<h4>Resource Links:</h4>

<!-- IHPC_ResourceLink_1 -->
<div id='div-gpt-ad-1410881227361-0' style='width:455px; height:50px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1410881227361-0'); });
</script>
</div>

<!-- IHPC_ResourceLink_2 -->
<div id='div-gpt-ad-1410881194676-0' style='width:455px; height:50px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1410881194676-0'); });
</script>
</div>

<!-- IHPC_ResourceLink_3 -->
<div id='div-gpt-ad-1410879732407-0' style='width:455px; height:50px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1410879732407-0'); });
</script>
</div>

</div></div><div id="sidebar" class="sidebar widget-area"><div id="enhancedtextwidget-10" class="widget widget_text enhanced-text-widget"><div class="widget-wrap"><div class="textwidget widget-text"><!-- 300x250_IHPC_ROS -->
<div id='div-gpt-ad-1407521768957-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1407521768957-0'); });
</script>
</div>
</div></div></div>
<div id="enhancedtextwidget-11" class="widget widget_text enhanced-text-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Latest Video</h4>
<div class="textwidget widget-text"><!-- 300x200_IHPC_Videowidget2 -->
<div id='div-gpt-ad-1408624752654-0' style='width:300px; height:200px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1408624752654-0'); });
</script>
</div>
<p class="archive-label"><a href="http://insidehpc.com/category/resources/video/">Recent Videos</a></p></div></div></div>
<div id="category-posts-2" class="widget cat-post-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Industry Perspectives</h4>
<ul id="category-posts-2-internal" class="category-posts-internal">
<li class='cat-post-item'><div><h2><a class="cat-post-title" href="https://insidehpc.com/2020/06/new-open-dpc-extensions-complement-sycl-and-c/" rel="bookmark">New, Open DPC++ Extensions Complement SYCL and C++</a></h2>
<a class="cat-post-thumbnail" href="https://insidehpc.com/2020/06/new-open-dpc-extensions-complement-sycl-and-c/" title="New, Open DPC++ Extensions Complement SYCL and C++"><img width="120" height="80" src="https://insidehpc.com/wp-content/uploads/2019/11/algorithms_shutterstock_531875605-150x100.jpg" class="attachment-120x120 size-120x120 wp-post-image" alt="" srcset="https://insidehpc.com/wp-content/uploads/2019/11/algorithms_shutterstock_531875605-150x100.jpg 150w, https://insidehpc.com/wp-content/uploads/2019/11/algorithms_shutterstock_531875605.jpg 300w" sizes="(max-width: 120px) 100vw, 120px" /></a>
<p>In this guest article, our friends at Intel discuss how accelerated computing has diversified over the past several years given advances in CPU, GPU, FPGA, and AI technologies. This innovation drives the need for an open and cross-platform language that allows developers to realize the potential of new hardware, minimizes development cost and complexity, and maximizes reuse of their software investments. <a class="cat-post-excerpt-more" href="https://insidehpc.com/2020/06/new-open-dpc-extensions-complement-sycl-and-c/" title="Continue reading New, Open DPC++ Extensions Complement SYCL and C++">[READ MORE&#8230;]</a></p></div></li></ul>
</div></div>
<div id="download_manager_widget-2" class="widget widget_download_manager_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">White Papers</h4>
			<div class="download-manager-widget ml-context-row">
			<a href="https://insidehpc.com/white-paper/smaller-faster-and-cooler-innovations-in-dell-precision-mobile-workstations-surmount-the-latest-thermal-challenges/"><img width="93" height="120" src="https://insidehpc.com/wp-content/uploads/2020/08/DellWPCover2_2020-08-26_11-19-14.jpg" class="attachment-120x120 size-120x120 wp-post-image" alt="" srcset="https://insidehpc.com/wp-content/uploads/2020/08/DellWPCover2_2020-08-26_11-19-14.jpg 232w, https://insidehpc.com/wp-content/uploads/2020/08/DellWPCover2_2020-08-26_11-19-14-116x150.jpg 116w" sizes="(max-width: 93px) 100vw, 93px" /></a>
			<h3><a class="ml-context-link" href="https://insidehpc.com/white-paper/smaller-faster-and-cooler-innovations-in-dell-precision-mobile-workstations-surmount-the-latest-thermal-challenges/">Smaller, faster and cooler: Innovations in Dell Precision mobile workstations surmount the latest thermal challenges</a></h3>
			<p><p>This white paper describes that with the latest Precision models, Dell continues to pioneer smarter thermals for mobile workstations that allow processor and GPU innovations to evolve so you can be more productive. To get the peak performance your demanding workloads require in easily portable sizes, Dell Technologies has Precision mobile workstations that best meets your needs.</p>
</p>
            <div class="button-download"><a href="https://insidehpc.com/white-paper/smaller-faster-and-cooler-innovations-in-dell-precision-mobile-workstations-surmount-the-latest-thermal-challenges/">Download</a></div>
            </div>
<a href="https://insidehpc.com/hpc-white-papers/">See More White Papers &raquo;</a></div></div>
<!-- END HERE --><div id="enhancedtextwidget-21" class="wpsnw-class widget widget_text enhanced-text-widget"><div class="wpsnw-class widget-wrap"><div class="textwidget widget-text"><h4 class="widget-title widgettitle">Find us on:</h4>
	<ul class="social-networks unstyled inline">
        <li class="twitter wpsnw-3x  display-icons">
            <a rel="external" title="twitter" target="_blank" href="https://twitter.com/insidehpc"><i class="icon-twitter"></i></a>
        </li>
        <li class="rss wpsnw-3x  display-icons">
            <a rel="external" title="rss" target="_blank" href="http://feeds.feedburner.com/insidehpc"><i class="icon-rss"></i></a>
        </li>
        <li class="linkedin wpsnw-3x  display-icons">
            <a rel="external" title="linkedin" target="_blank" href="http://www.linkedin.com/in/richbrueckner"><i class="icon-linkedin"></i></a>
        </li>
        <li class="google-plus wpsnw-3x  display-icons">
            <a rel="external" title="google-plus" target="_blank" href="https://plus.google.com/114354931073722933200/"><i class="icon-google-plus"></i></a>
        </li>
        <li class="youtube wpsnw-3x  display-icons">
            <a rel="external" title="youtube" target="_blank" href="https://www.youtube.com/user/RichReport/videos"><i class="icon-youtube"></i></a>
        </li>
	</ul>
</div></div></div>
</div></div><div id="sidebar-alt" class="sidebar widget-area"><div id="enhancedtextwidget-15" class="widget widget_text enhanced-text-widget"><div class="widget-wrap"><div class="textwidget widget-text"><div id='div-gpt-ad-1411648221207-0' style='width:160px; height:200px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1411648221207-0'); });
</script>
</div>

<!-- 160x600_IHPC_ROS -->
<div id='div-gpt-ad-1407521616271-0' style='width:160px; height:600px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1407521616271-0'); });
</script>
</div></div></div></div>
<div id="wpjobboard_widget-2" class="widget widget_wpjobboard_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Featured Job</h4>
<div class="featured-job"><h4><a href="https://insidehpc.com/job/research-scientist-and-postdoc-positions-in-heterogeneous-computing/">Research Scientist and Postdoc positions in Heterogeneous Computing</a></h4><center><img src="https://insidehpc.com/wp-content/uploads/wpjobboard/job/8602/company-logo/__64x64_simula_main_small_RGB.png" alt=""  /></center><strong>Simula Research Laboratory</strong><br/>Oslo<br/><div class="link"><a href="https://insidehpc.com/job/research-scientist-and-postdoc-positions-in-heterogeneous-computing/">Learn More &raquo;</a></div></div><div class="other-jobs"><h4>Other Jobs</h4><ul><li><a href="https://insidehpc.com/job/two-postdoc-positions-enabling-graph-neural-networks-at-exascale/">Two postdoc positions - Enabling Graph Neural Networks at Exascale</a></li><li><a href="https://insidehpc.com/job/senior-hpc-system-manager/">Senior HPC System Manager</a></li><li><a href="https://insidehpc.com/job/two-postdoc-positions-for-sparse-computations-on-emerging-processors/">Two postdoc positions for sparse computations on emerging processors</a></li></ul></div><div class="job-options"><center><a href="/jobs/">See all Jobs</a> | <a href="/jobs/post-a-job/">Post a Job</a></center></div></div></div>
</div></div></div><div id="footer-widgets" class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><div id="enhancedtextwidget-18" class="widget widget_text enhanced-text-widget"><div class="widget-wrap"><div class="textwidget widget-text"><p class="footer-content"><a href="/#top" title="back to top of page"><img src="/wp-content/themes/news-hpc/images/hpc-logo-stacked.png"></a></p>
<p>Copyright &copy; 2020</p></div></div></div>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><div id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-nav-middle-container"><ul id="menu-footer-nav-middle" class="menu"><li id="menu-item-39013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39013"><a href="https://insidehpc.com/about/">About insideHPC</a></li>
<li id="menu-item-39015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39015"><a href="https://insidehpc.com/contact/">Contact</a></li>
<li id="menu-item-39014" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39014"><a href="https://insidehpc.com/advertise/">Advertise with insideHPC</a></li>
</ul></div></div></div>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><div id="nav_menu-4" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-nav-right-container"><ul id="menu-footer-nav-right" class="menu"><li id="menu-item-40070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40070"><a href="http://www.insidebigdata.com/">Visit Our Other Site &#8211; insideBIGDATA</a></li>
<li id="menu-item-39017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39017"><a href="https://insidehpc.com/copyright-and-service-terms/">Copyright and Service Terms</a></li>
<li id="menu-item-39016" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39016"><a href="https://insidehpc.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></div></div>
</div></div></div><div id="footer" class="footer"><div class="wrap"><div class="gototop"><p><a href="#wrap" rel="nofollow">Return to top of page</a></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2020 &#x000B7; <a href="http://www.studiopress.com/themes/news">News Theme for Inside HPC</a> on <a href="https://www.studiopress.com/">Genesis Framework</a> &#x000B7; <a href="https://wordpress.org/">WordPress</a> &#x000B7; <a rel="nofollow" href="https://insidehpc.com/wp-login.php">Log in</a></p></div></div></div></div>            <script>
                jQuery(function($){
                                        try {
                        $('a.wpdm-lightbox').nivoLightbox();
                    } catch (e) {

                    }
                });
            </script>

                <div id="fb-root"></div>
    	<div style="display:none">
	</div>


<broadstreet-zone zone-id="59513"></broadstreet-zone>       <script type="text/javascript">

          var pfHeaderImgUrl = 'http://insidehpc.staging.wpengine.com/wp-content/themes/news-hpc/images/hpc-logo-stacked.png';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '1';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<link rel='stylesheet' id='shariffcss-css'  href='https://insidehpc.com/wp-content/plugins/shariff/css/shariff.min.css?ver=4.6.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/insidehpc.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1-b-modified-1603028305'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202044'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=-b-modified-1603028300'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.5-b-modified-1603028297'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.7.3-b-modified-1603028298'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/themes/genesis/lib/js/menu/superfish.compat.min.js?ver=2.7.3-b-modified-1603028298'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=13.0-b-modified-1603028297'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://insidehpc.com/wp-content/plugins/shariff/js/shariff.min.js?ver=4.6.2'></script>
<script async="async" type='text/javascript' src='https://insidehpc.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202044.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.2',blog:'57143778',post:'86073',tz:'-7',srv:'insidehpc.com'} ]);
	_stq.push([ 'clickTrackerInit', '57143778', '86073' ]);
</script>
</body></html>
